Загрузка...
Linux
Новости, статьи, обсуждения, - все что связано с GNU Linux, FreeBSD, OpenBSD, Sun Solaris, Mac OS X и другими системами. Если вы интересуетесь данной темой - добро пожаловать в сообщество.
     

Настройка звука 5.1 в Ubuntu и Debian

15.04.10, 01:30
Автор fry

Иногда многоканальный звук 5.1 может не работать в Ubuntu, или же работать некорректно. Для того, чтобы заставить его трудиться как положено необходимо проделать следующие действия:

  1. копируем два файла /etc/pulse/daemon.conf и /etc/pulse/default.pa в папку ~/.pulse
  2. открываем вашим любимым текстовым редактором файл ~/.pulse/daemon.conf и ищем там строчку вида ; default-sample-channels = 2
  3. раскомментируем данную строку (удаляем точку с запятой в начале) и поменяем цифру 2 на 6 (ибо звук шестиканальный)
  4. сохраняем файл
  5. перезагружаем систему

После данных махинаций многоканальный звук работает практически во всех случаях.

Комментарии

интересный способ! Я помню в свое время не смог пересадить брата на Linux и одной из причин была невозможность настроить систему 5.1

ничё не работает!
Ubuntu 10.04
пять часов секса
них*я не работает 5.1!!
нервы сдают
неужели ета ось умеет всё, но не может определить все колонки? я не верю

хм, напиши модель аудиокарточки, модель системы 5.1, что делал, что получается, тогда попробую помочь

система не 5.1, на самом деле 4.1 (2.0 колонки + 2.1 система).
Но в поисках такого не найдёшь, поетому ищу способ “завести” 5.1
аудиокарточка (вывод команды lspci): nVidia Corporation MCP61 High Definition Audio

работает только 1 выход аудиокарты, сама убунта в настройках звуках кроме режима стерео ничё не предлагает (перепробовал Ваш способ, правил asoundrc)

предлагаю посмотреть следующие темы:
https://help.ubuntu.com/community/SurroundSound
http://ubuntulinuxhelp.com/the-simple-way-to-get-51-surround-sound-audio-working-in-ubuntu/
http://ubuntuforums.org/showthread.php?t=205449
Если поможет очень прошу отписаться в комментах что именно помогло – я добавлю это в статью. Если не поможет – тоже неплохо было бы отписаться в комментах, будем дальше искать способ решить указанную проблему

Привет всем желающим разобраться с этой проблемой, .Поставил на свой комп убумту, так же как и у вас работало 2-ве колонки , пробовал изменять числа в папке пульс-не получалось .
Вот что сделал:
нажимаем ctrl-alt-t,затем вписываем в строку elsamixer,
появляется своего рода эквалайзер , там нужно выставить шести канальный звук, и приподнять шкалы фронтальных и тыловых колонок, ну вобщем разобраться можно.
Перезагружаем компьютер, и в настройках звука выбираем параметры выбранного устройства выставляем профиль где есть надпись к примеру :аналог сурраунд 5.1 или подобное.
Звук должен появиться. желаю всем успешной установки.

ощем ничё не получается, уяснил только одно: убунта с одним из выходом аудиокарты никак не хочет работать

Очень хочется больше конкретики, что значит ничего не получается? Хочется следующего: делаю то-то, реакция такая, в логах pulse audio то-то, использую такой-то плейер, pulseaudio перезагружаю (или не перезагружаю, в зависимости от ситуации). Чем больше информации, тем проще решается проблема. Нерешаемых проблем очень и очень мало.

вот еще одна подобная тема http://forum.ubuntu.ru/index.php?topic=9966.75 может помочь

самая первая ссылка уже немного помогла
по крайней мере я сконфигурировал 4.0 систему и запустился тест
вот только тыловые колонки по-прежнему молча стоят
осталось выяснить, почему же они так упорно не хотят работать

а что говорит speaker-test? Колонки молчат? Или speaker-test проходит нормально, а проблема в плеере?

на speaker-test только фронтальные колонки работают, тыл молчит

раз молчит – проблема в Alsa, ссылка в помощь: http://alsa.opensrc.org/SurroundSound

можетпишу не туда но у меня проблема немогу настроить звук
я новичок liux ставлю впервые
:не могу настроить звук Debian Lenny ноутбук HP pavilion entertainment PC dv6-2110er
#alsaconf
hda-intel ATI Technologies Inc SBx00 Azalia (Intel HDA)
hda-intel ATI Technologies Inc Device aa38

ммм, ну собственно подробнее: что делаешь конкретно, что получается?

Максим 30 мая 2011, 0:01
0

Доброго времени у меня Realtec звук.карта. 7ка умеет (после уст. дров) подавать отдельный звук в наушники, подключаемые спереди сист.блока и колонки подключаемые сзади. А это же реально сделать в Убунту 11?

думаю, да

Максим 30 мая 2011, 11:52
0

Подскажите, как это сделать. Сейчас у меня наушники в Убунту вообще не работают…

для начала можно попробовать в настройках аудио (апплет в панельке сверху) поменять output-устройство, обычно этого достаточно, но если не поможет пишите – будем дальше думать

Максим 30 мая 2011, 13:21
0

При указании выход- наушники, звук исчезает вообще. Или колонки или тишина.

аноним 30 мая 2011, 18:02
0

у меня похожая ситуация, если найдете ответ – пожалуйста отпишитесь

у меня примерно такая же ситуация с аудиокарточкой:
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
руки никак не дойдут починить, поэтому приходится втыкать наушники и микрофон в задний разъем…

Может надо драйвер скачать?

это только если есть такой драйвер…

Спасибо Вам большое. :)

не могу найти папку ~/.pulse (

если ее нет – нужно ее создать

Привет всем желающим разобраться с этой проблемой, .Поставил на свой комп убумту, так же как и у вас работало 2-ве колонки , пробовал изменять числа в папке пульс-не получалось .
Вот что сделал:
нажимаем ctrl-alt-t,затем вписываем в строку elsamixer,
появляется своего рода эквалайзер , там нужно выставить шести канальный звук, и приподнять шкалы фронтальных и тыловых колонок, ну вобщем разобраться можно.
Перезагружаем компьютер, и в настройках звука выбираем параметры выбранного устройства выставляем профиль где есть надпись к примеру :аналог сурраунд 5.1 или подобное.
Звук должен появиться. желаю всем успешной установки.

Yurecnt.ru 30 мая 2014, 19:27
0

не alsamixer а alsamixer =) у меня получилось просто зайти в настройки звука, выбрать карточку Аналоговый выход и режим – 5.1 и все путем

ubuntu 13.10 в терминале прописал alsamixer открылось окошко эквалайзера , в нем промотал направо и выбрал 6 каналов, звук появился

Войдите, чтобы оставить комментарий